CVE-2017-1000488 Inline JS XSS vulnerability in Mautic
An attacker can execute arbitrary JavaScript in a victim's browser via crafted GET parameters in Mautic landing page forms.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-1000488?
CVE-2017-1000488 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.
Weakness: CWE-79
Which versions are affected by CVE-2017-1000488?
2 open source packages ship an affected version, including mautic/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mautic/core Packagist | From 2.1.0 | 2.12.0 |
mautic/core Packagist | From 2.1.0 | 2.12.0 |
Products include Acquia Mautic, Mautic Mautic.
How do I fix CVE-2017-1000488?
Upgrade mautic/core to 2.12.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-1000488 being exploited?
There is no known exploitation of CVE-2017-1000488 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2022-25772 Cross-site Scripting vulnerability in Mautic's tracking pixel functionality
- CVE-2020-35125 Mautic is vulnerable to XSS vulnerability
- CVE-2020-35124 XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic
- CVE-2024-47051 Remote Code Execution & File Deletion in Asset Uploads
- CVE-2020-35128 Mautic stored Cross-site Scripting (XSS)
Sources
Also known as GHSA-qjhr-c23f-w76q.