CVE-2017-1000489 Disabled users able to log in with third party SSO plugin
Disabled users can bypass authentication and log in via email when the SSO plugin is installed in Mautic.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-1000489?
CVE-2017-1000489 is a high-severity authentication bypass vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address
Weakness: CWE-287
Which versions are affected by CVE-2017-1000489?
2 open source packages ship an affected version, including mautic/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mautic/core Packagist | From 2.0.0 | 2.12.0 |
mautic/core Packagist | From 2.0.0 | 2.12.0 |
Products include Acquia Mautic, Mautic Mautic.
How do I fix CVE-2017-1000489?
Upgrade mautic/core to 2.12.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2017-1000489 being exploited?
There is no known exploitation of CVE-2017-1000489 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2022-25772 Cross-site Scripting vulnerability in Mautic's tracking pixel functionality
- CVE-2020-35125 Mautic is vulnerable to XSS vulnerability
- CVE-2020-35124 XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic
- CVE-2024-47051 Remote Code Execution & File Deletion in Asset Uploads
- CVE-2020-35128 Mautic stored Cross-site Scripting (XSS)
Sources
Also known as GHSA-6x98-fx9j-7c78.