{"answers":{"affected":"2 open source packages ship an affected version, including mautic/core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-1000489 in the wild and no public exploit code.","fix":"Upgrade mautic/core to 2.12.0 or later.","what":"CVE-2017-1000489 is a high-severity authentication bypass vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000489 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000489 is a high-severity authentication bypass vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000489 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mautic/core (Packagist): affected from 2.0.0; fixed in 2.12.0\n- mautic/core (Packagist): affected from 2.0.0; fixed in 2.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000489/ (Markdown: https://insights.sbomify.com/CVE-2017-1000489/index.md)","id":"CVE-2017-1000489","markdown":"https://insights.sbomify.com/CVE-2017-1000489/index.md","name":"CVE-2017-1000489","record":{"aliases":["GHSA-6x98-fx9j-7c78"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Mautic SSO plugin","requires_auth":"none","summary":"Disabled users can bypass authentication and log in via email when the SSO plugin is installed in Mautic.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mautic","vendor":"acquia"},{"product":"mautic","vendor":"mautic"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Disabled users able to log in with third party SSO plugin","id":"CVE-2017-1000489","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Mautic users able to download any files from server using filemanager","id":"CVE-2017-1000490"},"packages":[{"ecosystem":"Packagist","fixed":["2.12.0"],"introduced":["2.0.0"],"last_affected":[],"package":"mautic/core","purl":null,"source":"GHSA-6x98-fx9j-7c78"},{"ecosystem":"Packagist","fixed":["2.12.0"],"introduced":["2.0.0"],"last_affected":[],"package":"mautic/core","purl":"pkg:composer/mautic/core","source":"GHSA-6x98-fx9j-7c78"}],"prev":{"headline":"Inline JS XSS vulnerability in Mautic","id":"CVE-2017-1000488"},"products":["n/a"],"published":"2018-01-03","related":[{"cvss_score":9.6,"headline":"Cross-site Scripting vulnerability in Mautic's tracking pixel functionality","id":"CVE-2022-25772","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":9.6,"headline":"Mautic is vulnerable to XSS vulnerability","id":"CVE-2020-35125","kev_date_added":null,"published":"2021-02-09"},{"cvss_score":9.6,"headline":"XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic","id":"CVE-2020-35124","kev_date_added":null,"published":"2021-01-28"},{"cvss_score":9.1,"headline":"Remote Code Execution \u0026 File Deletion in Asset Uploads","id":"CVE-2024-47051","kev_date_added":null,"published":"2025-02-26"},{"cvss_score":9,"headline":"Mautic stored Cross-site Scripting (XSS)","id":"CVE-2020-35128","kev_date_added":null,"published":"2021-01-19"},{"cvss_score":8.8,"headline":"Mautic Cross-Site Request Forgery (CSRF)","id":"CVE-2017-8874","kev_date_added":null,"published":"2017-05-10"},{"cvss_score":8.3,"headline":"Sensitive Data Exposure due to inadequate user permission settings","id":"CVE-2022-25776","kev_date_added":null,"published":"2024-09-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Disabled users can bypass authentication and log in via email when the SSO plugin is installed in Mautic.","url":"https://insights.sbomify.com/CVE-2017-1000489/"}