CVE-2017-1000491 Shiba vulnerable to XSS leading to code execution

Medium 6.1 Published Updated

Cross-site scripting in Shiba markdown preview allows remote code execution due to enabled Node integration.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-1000491?

CVE-2017-1000491 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Shiba markdown live preview app version 1.1.0 is vulnerable to XSS which leads to code execution due to enabled node integration.

Weakness: CWE-79

Which versions are affected by CVE-2017-1000491?

2 open source packages ship an affected version, including shiba. It affects 1 product.

PackageAffectedFixed in
shiba npmAll versions1.1.1
shiba npmAll versions1.1.1

Products include Shiba Project Shiba.

How do I fix CVE-2017-1000491?

Upgrade shiba to 1.1.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-1000491 being exploited?

There is no known exploitation of CVE-2017-1000491 in the wild and no public exploit code.

Sources

Also known as GHSA-jr64-pggr-j8xj.

Is CVE-2017-1000491 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free