# CVE-2017-1000495: QuickApps CMS Cross-site Scripting

> Stored XSS in QuickApps CMS allows attackers to perform unauthorized actions as an administrator and cause denial of service.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-825g-f3g2-6vxf

## What is CVE-2017-1000495?

CVE-2017-1000495 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jan 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

QuickApps CMS version 2.0.0 is vulnerable to Stored Cross-site Scripting in the user's real name field resulting in denial of service and performing unauthorised actions with an administrator user's account

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000495?

2 open source packages ship an affected version, including quickapps/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `quickapps/cms` | Packagist | All versions | 2.0.0 |
| `quickapps/cms` | Packagist | All versions | 2.0.0 |

Products: Quickappscms Quickapps Cms.

## How do I fix CVE-2017-1000495?

Upgrade quickapps/cms to 2.0.0 or later.

## Is CVE-2017-1000495 being exploited?

There is no known exploitation of CVE-2017-1000495 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-17102](https://insights.sbomify.com/CVE-2018-17102/): QuickAppsCMS Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2018-9108](https://insights.sbomify.com/CVE-2018-9108/): QuickAppsCMS Cross-Site Request Forgery (CSRF) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000495 and fix it if it is affected.

What it is: CVE-2017-1000495 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jan 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000495 in the wild and no public exploit code.

Affected packages and fixed versions:
- quickapps/cms (Packagist): affected all versions; fixed in 2.0.0
- quickapps/cms (Packagist): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000495/ (Markdown: https://insights.sbomify.com/CVE-2017-1000495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000495
- OSV: https://osv.dev/vulnerability/CVE-2017-1000495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000495/
Summaries are generated and may contain mistakes; the official description above is the record.
