CVE-2017-1000499 phpMyAdmin CSRF Vulnerability

High 8.8 Published Updated

Attackers can trick users into performing harmful database operations like deleting records or dropping tables via crafted URLs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-1000499?

CVE-2017-1000499 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.

Weakness: CWE-352

Which versions are affected by CVE-2017-1000499?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.

PackageAffectedFixed in
phpmyadmin/phpmyadmin PackagistFrom 4.74.7.7
phpmyadmin/phpmyadmin PackagistFrom 4.74.7.7

Products include Phpmyadmin Phpmyadmin.

How do I fix CVE-2017-1000499?

Upgrade phpmyadmin/phpmyadmin to 4.7.7 or later.

Is CVE-2017-1000499 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-1000499 exists.

Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.

All Phpmyadmin Phpmyadmin vulnerabilities

Sources

Also known as GHSA-f9hx-5jq4-fgjm.

Is CVE-2017-1000499 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free