{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-1000499 exists.","fix":"Upgrade phpmyadmin/phpmyadmin to 4.7.7 or later.","what":"CVE-2017-1000499 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000499 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000499 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-1000499 exists.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.7; fixed in 4.7.7\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.7; fixed in 4.7.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000499/ (Markdown: https://insights.sbomify.com/CVE-2017-1000499/index.md)","id":"CVE-2017-1000499","markdown":"https://insights.sbomify.com/CVE-2017-1000499/index.md","name":"CVE-2017-1000499","record":{"aliases":["GHSA-f9hx-5jq4-fgjm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Database management tool","requires_auth":"none","summary":"Attackers can trick users into performing harmful database operations like deleting records or dropping tables via crafted URLs.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2018-08-29","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-08-29","kind":"exploitdb","ref":"45284","stars":null,"title":"phpMyAdmin 4.7.x - Cross-Site Request Forgery"},{"date":"2019-01-05T16:33:08Z","kind":"github_poc","ref":"https://github.com/Villaquiranm/5MMISSI-CVE-2017-1000499","stars":0,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"phpMyAdmin CSRF Vulnerability","id":"CVE-2017-1000499","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"csrf","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"Path traversal in n/a","id":"CVE-2017-1000501"},"packages":[{"ecosystem":"Packagist","fixed":["4.7.7"],"introduced":["4.7"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-f9hx-5jq4-fgjm"},{"ecosystem":"Packagist","fixed":["4.7.7"],"introduced":["4.7"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-f9hx-5jq4-fgjm"}],"prev":{"headline":"Android SVG vulnerable to XML External Entity (XXE)","id":"CVE-2017-1000498"},"products":["n/a"],"published":"2018-01-03","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can trick users into performing harmful database operations like deleting records or dropping tables via crafted URLs.","url":"https://insights.sbomify.com/CVE-2017-1000499/"}