# CVE-2017-1000502: Arbitrary shell command execution in Jenkins EC2 Plugin

> Users with agent configuration permissions can execute arbitrary shell commands on the Jenkins master node by configuring EC2 agents.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wp79-cpv2-9g7m

## What is CVE-2017-1000502?

CVE-2017-1000502 is a high-severity command injection vulnerability in n/a, published on 24 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Users with permission to create or configure agents in Jenkins 1.37 and earlier could configure an EC2 agent to run arbitrary shell commands on the master node whenever the agent was supposed to be launched. Configuration of these agents now requires the 'Run Scripts' permission typically only granted to administrators.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2017-1000502?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ec2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ec2` | Maven | All versions | 1.38 |
| `org.jenkins-ci.plugins:ec2` | Maven | All versions | 1.38 |

Products: Jenkins Ec2.

## How do I fix CVE-2017-1000502?

Upgrade org.jenkins-ci.plugins:ec2 to 1.38 or later.

## Is CVE-2017-1000502 being exploited?

There is no known exploitation of CVE-2017-1000502 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-10364](https://insights.sbomify.com/CVE-2019-10364/): Jenkins Amazon EC2 Plugin leaked beginning of private key in system log (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000502 and fix it if it is affected.

What it is: CVE-2017-1000502 is a high-severity command injection vulnerability in n/a, published on 24 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000502 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ec2 (Maven): affected all versions; fixed in 1.38
- org.jenkins-ci.plugins:ec2 (Maven): affected all versions; fixed in 1.38

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000502/ (Markdown: https://insights.sbomify.com/CVE-2017-1000502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000502
- OSV: https://osv.dev/vulnerability/CVE-2017-1000502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000502/
Summaries are generated and may contain mistakes; the official description above is the record.
