CVE-2017-1000503 Race Condition in Jenkins

High 8.1 Published Updated

A race condition during Jenkins startup may prevent the setup wizard from running, leaving security settings in a less strict default state.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000503?

CVE-2017-1000503 is a high-severity vulnerability in Jenkins Jenkins, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A race condition during Jenkins 2.81 through 2.94 (inclusive); 2.89.1 startup could result in the wrong order of execution of commands during initialization. This could in rare cases result in failure to initialize the setup wizard on the first startup. This resulted in multiple security-related settings not being set to their usual strict default.

Weakness: CWE-362

Which versions are affected by CVE-2017-1000503?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenFrom 2.812.89.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.812.89.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.902.95
org.jenkins-ci.main:jenkins-core MavenFrom 2.902.95

Products include Jenkins Jenkins.

How do I fix CVE-2017-1000503?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.89.2 or 2.95.

Is CVE-2017-1000503 being exploited?

There is no known exploitation of CVE-2017-1000503 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-r5x3-2446-hrp7.

Is CVE-2017-1000503 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free