# CVE-2017-1000504: Cross-Site Request Forgery in Jenkins

> A race condition during Jenkins startup allows attackers to bypass CSRF protection within a short initialization window.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-99hj-ppg3-2xwc

## What is CVE-2017-1000504?

CVE-2017-1000504 is a high-severity vulnerability in Jenkins Jenkins, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A race condition during Jenkins 2.94 and earlier; 2.89.1 and earlier startup could result in the wrong order of execution of commands during initialization. There is a very short window of time after startup during which Jenkins may no longer show the 'Please wait while Jenkins is getting ready to work' message but Cross-Site Request Forgery (CSRF) protection may not yet be effective.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-1000504?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.81 | 2.89.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.81 | 2.89.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.90 | 2.95 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.90 | 2.95 |

Products: Jenkins Jenkins.

## How do I fix CVE-2017-1000504?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.89.2 or 2.95.

## Is CVE-2017-1000504 being exploited?

There is no known exploitation of CVE-2017-1000504 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000504 and fix it if it is affected.

What it is: CVE-2017-1000504 is a high-severity vulnerability in Jenkins Jenkins, published on 24 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000504 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.81; fixed in 2.89.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.81; fixed in 2.89.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.90; fixed in 2.95
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.90; fixed in 2.95

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000504/ (Markdown: https://insights.sbomify.com/CVE-2017-1000504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000504
- OSV: https://osv.dev/vulnerability/CVE-2017-1000504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000504/
Summaries are generated and may contain mistakes; the official description above is the record.
