# CVE-2017-1000505: Exposure of Sensitive Information to an Unauthorized Actor Jenkins Script Security Plugin

> Attackers with script configuration rights can read arbitrary files on the Jenkins master via Groovy type coercion bypassing sandbox restrictions.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-r9jf-hf9x-7hrv

## What is CVE-2017-1000505?

CVE-2017-1000505 is a medium-severity path traversal vulnerability in n/a, published on 25 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Jenkins Script Security Plugin version 1.36 and earlier, users with the ability to configure sandboxed Groovy scripts are able to use a type coercion feature in Groovy to create new `File` objects from strings. This allowed reading arbitrary files on the Jenkins master file system. Such a type coercion is now subject to sandbox protection and considered to be a call to the `new File(String)` constructor for the purpose of in-process script approval.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-1000505?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.37 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.37 |

Products: Jenkins Script Security.

## How do I fix CVE-2017-1000505?

Upgrade org.jenkins-ci.plugins:script-security to 1.37 or later.

## Is CVE-2017-1000505 being exploited?

There is no known exploitation of CVE-2017-1000505 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000505 and fix it if it is affected.

What it is: CVE-2017-1000505 is a medium-severity path traversal vulnerability in n/a, published on 25 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000505 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.37
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.37

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000505/ (Markdown: https://insights.sbomify.com/CVE-2017-1000505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000505
- OSV: https://osv.dev/vulnerability/CVE-2017-1000505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000505/
Summaries are generated and may contain mistakes; the official description above is the record.
