{"answers":{"affected":"2 open source packages ship an affected version, including mautic/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000506 in the wild and no public exploit code.","fix":"Upgrade mautic/core to 2.14.2 or later.","what":"CVE-2017-1000506 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000506 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000506 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000506 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mautic/core (Packagist): affected all versions; fixed in 2.14.2\n- mautic/core (Packagist): affected all versions; fixed in 2.14.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000506/ (Markdown: https://insights.sbomify.com/CVE-2017-1000506/index.md)","id":"CVE-2017-1000506","markdown":"https://insights.sbomify.com/CVE-2017-1000506/index.md","name":"CVE-2017-1000506","record":{"aliases":["GHSA-358v-cqjc-2pcq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Mautic marketing automation","requires_auth":"none","summary":"An attacker can inject malicious JavaScript via company names in Mautic, leading to code execution or denial of service.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mautic","vendor":"mautic"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Mautic version 2.11.0 and earlier contains a Cross Site Scripting (XSS) vulnerability in Company's name that can result in denial of service and execution of javascript code.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mautic Cross Site Scripting (XSS) vulnerability","id":"CVE-2017-1000506","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Canvs Canvas XSS Vulnerability","id":"CVE-2017-1000507"},"packages":[{"ecosystem":"Packagist","fixed":["2.14.2"],"introduced":["0"],"last_affected":[],"package":"mautic/core","purl":null,"source":"GHSA-358v-cqjc-2pcq"},{"ecosystem":"Packagist","fixed":["2.14.2"],"introduced":["0"],"last_affected":[],"package":"mautic/core","purl":"pkg:composer/mautic/core","source":"GHSA-358v-cqjc-2pcq"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor Jenkins Script Security Plugin","id":"CVE-2017-1000505"},"products":["n/a"],"published":"2018-02-09","related":[{"cvss_score":9.8,"headline":"CSV Injection vulnerability with exported contact lists in Mautic","id":"CVE-2018-8092","kev_date_added":null,"published":"2018-04-18"},{"cvss_score":9,"headline":"Mautic stored Cross-site Scripting (XSS)","id":"CVE-2020-35129","kev_date_added":null,"published":"2021-01-19"},{"cvss_score":7.5,"headline":"Mautic Sessions could be hijacked due to tracking contacts by an auto-incremented ID","id":"CVE-2018-10189","kev_date_added":null,"published":"2018-04-17"},{"cvss_score":7.5,"headline":"Sensitive Cookie Without HttpOnly and Secure Flag","id":"CVE-2017-1000046","kev_date_added":null,"published":"2017-07-13"},{"cvss_score":6.1,"headline":"XSS vulnerability in theme config file in Mautic","id":"CVE-2018-8071","kev_date_added":null,"published":"2018-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can inject malicious JavaScript via company names in Mautic, leading to code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2017-1000506/"}