CVE-2017-1000508 Cross-site scripting in n/a

Medium 6.1 Published Updated

An attacker can execute arbitrary JavaScript code in the context of other users via the Client's details feature in Invoice Plane.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-1000508?

CVE-2017-1000508 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Invoice Plane version 1.5.4 and earlier contains a Cross Site Scripting (XSS) vulnerability in Client's details that can result in execution of javascript code . This vulnerability appears to have been fixed in 1.5.5 and later.

Weakness: CWE-79

Which versions are affected by CVE-2017-1000508?

It affects 1 product.

Products include Invoiceplane Invoiceplane.

How do I fix CVE-2017-1000508?

No fix has been published for CVE-2017-1000508 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-1000508 being exploited?

There is no known exploitation of CVE-2017-1000508 in the wild and no public exploit code.

Sources

Also known as GHSA-p6q4-h4rq-q2x3.

Is CVE-2017-1000508 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free