# CVE-2017-1000509: Dolibarr ERP and CRM contain XSS Vulnerability

> An attacker can execute arbitrary JavaScript code in the context of other users via a Cross-Site Scripting vulnerability in Dolibarr product details.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hqfh-p9h7-m6v5, UBUNTU-CVE-2017-1000509

## What is CVE-2017-1000509?

CVE-2017-1000509 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 9 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Dolibarr version 6.0.2 contains a Cross Site Scripting (XSS) vulnerability in Product details that can result in execution of javascript code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000509?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 7.0.0 |
| `dolibarr/dolibarr` | Packagist | All versions | 7.0.0 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2017-1000509?

Upgrade dolibarr/dolibarr to 7.0.0 or later.

## Is CVE-2017-1000509 being exploited?

There is no known exploitation of CVE-2017-1000509 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000509 and fix it if it is affected.

What it is: CVE-2017-1000509 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 9 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000509 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 7.0.0
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000509/ (Markdown: https://insights.sbomify.com/CVE-2017-1000509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000509
- OSV: https://osv.dev/vulnerability/CVE-2017-1000509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000509/
Summaries are generated and may contain mistakes; the official description above is the record.
