# CVE-2017-1001002: Arbitrary Code Execution in mathjs

> Attackers can execute arbitrary code by crafting malicious function names in the math.js library, requiring developers to upgrade to a patched version.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vx5c-87qx-cv6c

## What is CVE-2017-1001002?

CVE-2017-1001002 is a critical code injection vulnerability in math.js, published on 27 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2017-1001002?

2 open source packages ship an affected version, including mathjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mathjs` | npm | All versions | 3.17.0 |
| `mathjs` | npm | All versions | 3.17.0 |

Products: Mathjs Math.js.

## How do I fix CVE-2017-1001002?

Upgrade mathjs to 3.17.0 or later.

## Is CVE-2017-1001002 being exploited?

There is no known exploitation of CVE-2017-1001002 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1001002 and fix it if it is affected.

What it is: CVE-2017-1001002 is a critical code injection vulnerability in math.js, published on 27 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1001002 in the wild and no public exploit code.

Affected packages and fixed versions:
- mathjs (npm): affected all versions; fixed in 3.17.0
- mathjs (npm): affected all versions; fixed in 3.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1001002/ (Markdown: https://insights.sbomify.com/CVE-2017-1001002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1001002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1001002
- OSV: https://osv.dev/vulnerability/CVE-2017-1001002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1001002/
Summaries are generated and may contain mistakes; the official description above is the record.
