CVE-2017-1002102 Kubernetes arbitrary file overwrite

High 7.1 Published Updated

Attackers can delete arbitrary files on Kubernetes nodes by exploiting volume mounting mechanisms, potentially causing service disruption or data loss.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1002102?

CVE-2017-1002102 is a high-severity path traversal vulnerability in Kubernetes Kubernetes, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using a secret, configMap, projected or downwardAPI volume can trigger deletion of arbitrary files/directories from the nodes where they are running.

Which versions are affected by CVE-2017-1002102?

7 open source packages ship an affected version, including k8s.io/kubernetes. It affects 1 product.

PackageAffectedFixed in
k8s.io/kubernetes GoFrom 1.3.01.7.14, 1.8.9, 1.9.4
k8s.io/kubernetes GoFrom 1.3.01.7.14
k8s.io/kubernetes GoFrom 1.3.01.7.14
k8s.io/kubernetes GoFrom 1.8.01.8.9
k8s.io/kubernetes GoFrom 1.8.01.8.9
k8s.io/kubernetes GoFrom 1.9.01.9.4
1 more packages
k8s.io/kubernetes GoFrom 1.9.01.9.4

Products include Kubernetes Kubernetes.

How do I fix CVE-2017-1002102?

Upgrade k8s.io/kubernetes to a fixed version for your release line: 1.7.14, 1.8.9 or 1.9.4.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2017-1002102 being exploited?

There is no known exploitation of CVE-2017-1002102 in the wild and no public exploit code.

All Kubernetes Kubernetes vulnerabilities

Sources

Also known as DEBIAN-CVE-2017-1002102, GHSA-mm7g-f2gg-cw8g, GO-2023-1977.

Is CVE-2017-1002102 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free