# CVE-2017-1002102: Kubernetes arbitrary file overwrite

> Attackers can delete arbitrary files on Kubernetes nodes by exploiting volume mounting mechanisms, potentially causing service disruption or data loss.

- **Severity:** High 7.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-1002102, GHSA-mm7g-f2gg-cw8g, GO-2023-1977

## What is CVE-2017-1002102?

CVE-2017-1002102 is a high-severity path traversal vulnerability in Kubernetes Kubernetes, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using a secret, configMap, projected or downwardAPI volume can trigger deletion of arbitrary files/directories from the nodes where they are running.

## Which versions are affected by CVE-2017-1002102?

7 open source packages ship an affected version, including k8s.io/kubernetes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `k8s.io/kubernetes` | Go | From 1.3.0 | 1.7.14, 1.8.9, 1.9.4 |
| `k8s.io/kubernetes` | Go | From 1.3.0 | 1.7.14 |
| `k8s.io/kubernetes` | Go | From 1.3.0 | 1.7.14 |
| `k8s.io/kubernetes` | Go | From 1.8.0 | 1.8.9 |
| `k8s.io/kubernetes` | Go | From 1.8.0 | 1.8.9 |
| `k8s.io/kubernetes` | Go | From 1.9.0 | 1.9.4 |
| `k8s.io/kubernetes` | Go | From 1.9.0 | 1.9.4 |

Products: Kubernetes Kubernetes.

## How do I fix CVE-2017-1002102?

Upgrade k8s.io/kubernetes to a fixed version for your release line: 1.7.14, 1.8.9 or 1.9.4.

## Is CVE-2017-1002102 being exploited?

There is no known exploitation of CVE-2017-1002102 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Kubernetes

- [CVE-2018-1002105](https://insights.sbomify.com/CVE-2018-1002105/): Privilege Escalation in Kubernetes (critical 9.8)
- [CVE-2017-1000056](https://insights.sbomify.com/CVE-2017-1000056/): Kubernetes Privilege Escalation (critical 9.8)
- [CVE-2016-1906](https://insights.sbomify.com/CVE-2016-1906/): Authorization bypass in Openshift (critical 9.8)
- [CVE-2023-3676](https://insights.sbomify.com/CVE-2023-3676/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2023-3955](https://insights.sbomify.com/CVE-2023-3955/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1002102 and fix it if it is affected.

What it is: CVE-2017-1002102 is a high-severity path traversal vulnerability in Kubernetes Kubernetes, published on 13 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1002102 in the wild and no public exploit code.

Affected packages and fixed versions:
- k8s.io/kubernetes (Go): affected from 1.3.0; fixed in 1.7.14, 1.8.9, 1.9.4
- k8s.io/kubernetes (Go): affected from 1.3.0; fixed in 1.7.14
- k8s.io/kubernetes (Go): affected from 1.3.0; fixed in 1.7.14
- k8s.io/kubernetes (Go): affected from 1.8.0; fixed in 1.8.9
- k8s.io/kubernetes (Go): affected from 1.8.0; fixed in 1.8.9
- k8s.io/kubernetes (Go): affected from 1.9.0; fixed in 1.9.4
- k8s.io/kubernetes (Go): affected from 1.9.0; fixed in 1.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1002102/ (Markdown: https://insights.sbomify.com/CVE-2017-1002102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1002102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1002102
- OSV: https://osv.dev/vulnerability/CVE-2017-1002102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1002102/
Summaries are generated and may contain mistakes; the official description above is the record.
