# CVE-2017-1002150: python-fedora vulnerable to an open redirect resulting in loss of CSRF protection

> An open redirect in python-fedora allows attackers to bypass CSRF protection mechanisms.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-1002150, GHSA-m242-wc86-8768, PYSEC-2017-27, UBUNTU-CVE-2017-1002150

## What is CVE-2017-1002150?

CVE-2017-1002150 is a medium-severity vulnerability in Python-Fedora, published on 14 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

python-fedora 0.8.0 and lower is vulnerable to an open redirect resulting in loss of CSRF protection

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2017-1002150?

3 open source packages ship an affected version, including python-fedora. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-fedora` | PyPI | All versions | 0.9.0 |
| `python-fedora` | PyPI | All versions | 0.9.0 |
| `python-fedora` | PyPI | All versions | 0.9.0 |

Products: Fedoraproject Python-Fedora.

## How do I fix CVE-2017-1002150?

Upgrade python-fedora to 0.9.0 or later.

## Is CVE-2017-1002150 being exploited?

There is no known exploitation of CVE-2017-1002150 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1002150 and fix it if it is affected.

What it is: CVE-2017-1002150 is a medium-severity vulnerability in Python-Fedora, published on 14 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1002150 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-fedora (PyPI): affected all versions; fixed in 0.9.0
- python-fedora (PyPI): affected all versions; fixed in 0.9.0
- python-fedora (PyPI): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1002150/ (Markdown: https://insights.sbomify.com/CVE-2017-1002150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1002150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1002150
- OSV: https://osv.dev/vulnerability/CVE-2017-1002150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1002150/
Summaries are generated and may contain mistakes; the official description above is the record.
