CVE-2017-1002152 Bodhi Cross-site Scripting Vulnerability
Attackers can inject malicious scripts via bug titles in Bodhi, potentially executing code or bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-1002152?
CVE-2017-1002152 is a medium-severity cross-site scripting vulnerability in Fedora Project Infrastructure Bodhi, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.
Which versions are affected by CVE-2017-1002152?
3 open source packages ship an affected version, including bodhi. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
bodhi PyPI | All versions | 2.9.1 |
bodhi PyPI | All versions | 2.9.1 |
bodhi PyPI | All versions | 3.3.0 |
Products include Redhat Bodhi.
How do I fix CVE-2017-1002152?
Upgrade bodhi to a fixed version for your release line: 2.9.1 or 3.3.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-1002152 being exploited?
There is no known exploitation of CVE-2017-1002152 in the wild and no public exploit code.
Other vulnerabilities in Fedora Project Infrastructure Bodhi
Sources
Also known as GHSA-h896-6hcp-gj6c, PYSEC-2019-150.