{"answers":{"affected":"3 open source packages ship an affected version, including bodhi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1002152 in the wild and no public exploit code.","fix":"Upgrade bodhi to a fixed version for your release line: 2.9.1 or 3.3.0.","what":"CVE-2017-1002152 is a medium-severity cross-site scripting vulnerability in Fedora Project Infrastructure Bodhi, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1002152 and fix it if it is affected.\n\nWhat it is: CVE-2017-1002152 is a medium-severity cross-site scripting vulnerability in Fedora Project Infrastructure Bodhi, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1002152 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bodhi (PyPI): affected all versions; fixed in 2.9.1\n- bodhi (PyPI): affected all versions; fixed in 2.9.1\n- bodhi (PyPI): affected all versions; fixed in 3.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1002152/ (Markdown: https://insights.sbomify.com/CVE-2017-1002152/index.md)","id":"CVE-2017-1002152","markdown":"https://insights.sbomify.com/CVE-2017-1002152/index.md","name":"CVE-2017-1002152","record":{"aliases":["GHSA-h896-6hcp-gj6c","PYSEC-2019-150"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Bodhi update system","requires_auth":"none","summary":"Attackers can inject malicious scripts via bug titles in Bodhi, potentially executing code or bypassing security controls.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"bodhi","vendor":"redhat"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bodhi Cross-site Scripting Vulnerability","id":"CVE-2017-1002152","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"Koji blacklisted paths workaround","id":"CVE-2017-1002153"},"packages":[{"ecosystem":"PyPI","fixed":["2.9.1"],"introduced":["0"],"last_affected":[],"package":"bodhi","purl":null,"source":"GHSA-h896-6hcp-gj6c"},{"ecosystem":"PyPI","fixed":["2.9.1"],"introduced":["0"],"last_affected":[],"package":"bodhi","purl":"pkg:pypi/bodhi","source":"GHSA-h896-6hcp-gj6c"},{"ecosystem":"PyPI","fixed":["3.3.0"],"introduced":["0"],"last_affected":[],"package":"bodhi","purl":"pkg:pypi/bodhi","source":"PYSEC-2019-150"}],"prev":{"headline":"Missing authorization in Pagure","id":"CVE-2017-1002151"},"products":["Bodhi"],"published":"2019-01-10","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in bodhi","id":"CVE-2020-15855","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Fedora Project Infrastructure"]},"summary":"Attackers can inject malicious scripts via bug titles in Bodhi, potentially executing code or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2017-1002152/"}