# CVE-2017-1002152: Bodhi Cross-site Scripting Vulnerability

> Attackers can inject malicious scripts via bug titles in Bodhi, potentially executing code or bypassing security controls.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h896-6hcp-gj6c, PYSEC-2019-150

## What is CVE-2017-1002152?

CVE-2017-1002152 is a medium-severity cross-site scripting vulnerability in Fedora Project Infrastructure Bodhi, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2017-1002152?

3 open source packages ship an affected version, including bodhi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bodhi` | PyPI | All versions | 2.9.1 |
| `bodhi` | PyPI | All versions | 2.9.1 |
| `bodhi` | PyPI | All versions | 3.3.0 |

Products: Redhat Bodhi.

## How do I fix CVE-2017-1002152?

Upgrade bodhi to a fixed version for your release line: 2.9.1 or 3.3.0.

## Is CVE-2017-1002152 being exploited?

There is no known exploitation of CVE-2017-1002152 in the wild and no public exploit code.

## Other vulnerabilities in Fedora Project Infrastructure Bodhi

- [CVE-2020-15855](https://insights.sbomify.com/CVE-2020-15855/): Cross-site scripting in bodhi (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1002152 and fix it if it is affected.

What it is: CVE-2017-1002152 is a medium-severity cross-site scripting vulnerability in Fedora Project Infrastructure Bodhi, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1002152 in the wild and no public exploit code.

Affected packages and fixed versions:
- bodhi (PyPI): affected all versions; fixed in 2.9.1
- bodhi (PyPI): affected all versions; fixed in 2.9.1
- bodhi (PyPI): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1002152/ (Markdown: https://insights.sbomify.com/CVE-2017-1002152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1002152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1002152
- OSV: https://osv.dev/vulnerability/CVE-2017-1002152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1002152/
Summaries are generated and may contain mistakes; the official description above is the record.
