{"answers":{"affected":"3 open source packages ship an affected version, including modulemd. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1002157 in the wild and no public exploit code.","fix":"Upgrade modulemd to 1.3.2 or later.","what":"CVE-2017-1002157 is a critical code injection vulnerability in Fedora Modularity modulemd, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1002157 and fix it if it is affected.\n\nWhat it is: CVE-2017-1002157 is a critical code injection vulnerability in Fedora Modularity modulemd, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1002157 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modulemd (PyPI): affected all versions; fixed in 1.3.2\n- modulemd (PyPI): affected all versions; fixed in 1.3.2\n- modulemd (PyPI): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1002157/ (Markdown: https://insights.sbomify.com/CVE-2017-1002157/index.md)","id":"CVE-2017-1002157","markdown":"https://insights.sbomify.com/CVE-2017-1002157/index.md","name":"CVE-2017-1002157","record":{"aliases":["GHSA-jhjh-ghwx-6h7r","PYSEC-2019-153"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python module metadata library","requires_auth":"none","summary":"An unsafe function in the modulemd library allows remote code execution when processing externally provided data.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"modulemd","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-242","name":"Use of Inherently Dangerous Function"}],"description":"modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"modulemd uses an unsafe function for processing externally provided data","id":"CVE-2017-1002157","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"Haml vulnerable to cross-site scripting","id":"CVE-2017-1002201"},"packages":[{"ecosystem":"PyPI","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"modulemd","purl":null,"source":"GHSA-jhjh-ghwx-6h7r"},{"ecosystem":"PyPI","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"modulemd","purl":"pkg:pypi/modulemd","source":"GHSA-jhjh-ghwx-6h7r"},{"ecosystem":"PyPI","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"modulemd","purl":"pkg:pypi/modulemd","source":"PYSEC-2019-153"}],"prev":{"headline":"Koji blacklisted paths workaround","id":"CVE-2017-1002153"},"products":["modulemd"],"published":"2019-01-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Fedora Modularity"]},"summary":"An unsafe function in the modulemd library allows remote code execution when processing externally provided data.","url":"https://insights.sbomify.com/CVE-2017-1002157/"}