# CVE-2017-1002157: modulemd uses an unsafe function for processing externally provided data

> An unsafe function in the modulemd library allows remote code execution when processing externally provided data.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-jhjh-ghwx-6h7r, PYSEC-2019-153

## What is CVE-2017-1002157?

CVE-2017-1002157 is a critical code injection vulnerability in Fedora Modularity modulemd, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.

Weakness: CWE-20 (Improper Input Validation), CWE-242 (Use of Inherently Dangerous Function)

## Which versions are affected by CVE-2017-1002157?

3 open source packages ship an affected version, including modulemd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modulemd` | PyPI | All versions | 1.3.2 |
| `modulemd` | PyPI | All versions | 1.3.2 |
| `modulemd` | PyPI | All versions | 1.3.2 |

Products: Redhat Modulemd.

## How do I fix CVE-2017-1002157?

Upgrade modulemd to 1.3.2 or later.

## Is CVE-2017-1002157 being exploited?

There is no known exploitation of CVE-2017-1002157 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1002157 and fix it if it is affected.

What it is: CVE-2017-1002157 is a critical code injection vulnerability in Fedora Modularity modulemd, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1002157 in the wild and no public exploit code.

Affected packages and fixed versions:
- modulemd (PyPI): affected all versions; fixed in 1.3.2
- modulemd (PyPI): affected all versions; fixed in 1.3.2
- modulemd (PyPI): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1002157/ (Markdown: https://insights.sbomify.com/CVE-2017-1002157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1002157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1002157
- OSV: https://osv.dev/vulnerability/CVE-2017-1002157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1002157/
Summaries are generated and may contain mistakes; the official description above is the record.
