{"answers":{"affected":"2 open source packages ship an affected version, including haml. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-1002201 in the wild and no public exploit code.","fix":"Upgrade haml to 5.0.0 or later.","what":"CVE-2017-1002201 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 15 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1002201 and fix it if it is affected.\n\nWhat it is: CVE-2017-1002201 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 15 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1002201 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- haml (RubyGems): affected all versions; fixed in 5.0.0\n- haml (RubyGems): affected all versions; fixed in 5.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1002201/ (Markdown: https://insights.sbomify.com/CVE-2017-1002201/index.md)","id":"CVE-2017-1002201","markdown":"https://insights.sbomify.com/CVE-2017-1002201/index.md","name":"CVE-2017-1002201","record":{"aliases":["DEBIAN-CVE-2017-1002201","DLA-1986-1","DLA-2864-1","GHSA-r53w-g4xm-3gc6","SNYK-RUBY-HAML-20362","SUSE-SU-2019:2932-1","UBUNTU-CVE-2017-1002201"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HAML library","requires_auth":"none","summary":"An attacker can inject malicious scripts via unescaped single quotes in user input, potentially executing code on the server.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"haml","vendor":"haml"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In haml versions prior to version 5.0.0.beta.2, when using user input to perform tasks on the server, characters like \u003c \u003e \" ' must be escaped properly. In this case, the ' character was missed. An attacker can manipulate the input to introduce additional attributes, potentially executing code.","ecosystems":["RubyGems","SUSE:OpenStack Cloud 7","SUSE:OpenStack Cloud Crowbar 8","SUSE:OpenStack Cloud Crowbar 9"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Haml vulnerable to cross-site scripting","id":"CVE-2017-1002201","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"xss","year":"2017"},"n_packages":5,"n_references":5,"next":{"headline":"Junos: Unauthenticated Remote Code Execution through J-Web interface","id":"CVE-2018-0001"},"packages":[{"ecosystem":"RubyGems","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"haml","purl":null,"source":"GHSA-r53w-g4xm-3gc6"},{"ecosystem":"RubyGems","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"haml","purl":"pkg:gem/haml","source":"GHSA-r53w-g4xm-3gc6"},{"ecosystem":"SUSE:OpenStack Cloud 7","fixed":["4.0.6-3.3.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-haml","purl":"pkg:rpm/suse/rubygem-haml\u0026distro=SUSE%20OpenStack%20Cloud%207","source":"SUSE-SU-2019:2932-1"},{"ecosystem":"SUSE:OpenStack Cloud Crowbar 8","fixed":["4.0.6-3.3.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-haml","purl":"pkg:rpm/suse/rubygem-haml\u0026distro=SUSE%20OpenStack%20Cloud%20Crowbar%208","source":"SUSE-SU-2019:2932-1"},{"ecosystem":"SUSE:OpenStack Cloud Crowbar 9","fixed":["4.0.6-3.3.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-haml","purl":"pkg:rpm/suse/rubygem-haml\u0026distro=SUSE%20OpenStack%20Cloud%20Crowbar%209","source":"SUSE-SU-2019:2932-1"}],"prev":{"headline":"modulemd uses an unsafe function for processing externally provided data","id":"CVE-2017-1002157"},"products":["haml"],"published":"2019-10-15","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["http://haml.info/"]},"summary":"An attacker can inject malicious scripts via unescaped single quotes in user input, potentially executing code on the server.","url":"https://insights.sbomify.com/CVE-2017-1002201/"}