# CVE-2017-1002201: Haml vulnerable to cross-site scripting

> An attacker can inject malicious scripts via unescaped single quotes in user input, potentially executing code on the server.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Oct 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-1002201, DLA-1986-1, DLA-2864-1, GHSA-r53w-g4xm-3gc6, SNYK-RUBY-HAML-20362, SUSE-SU-2019:2932-1, UBUNTU-CVE-2017-1002201

## What is CVE-2017-1002201?

CVE-2017-1002201 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 15 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In haml versions prior to version 5.0.0.beta.2, when using user input to perform tasks on the server, characters like < > " ' must be escaped properly. In this case, the ' character was missed. An attacker can manipulate the input to introduce additional attributes, potentially executing code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1002201?

2 open source packages ship an affected version, including haml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haml` | RubyGems | All versions | 5.0.0 |
| `haml` | RubyGems | All versions | 5.0.0 |
| `rubygem-haml` | SUSE:OpenStack Cloud 7 | All versions | 4.0.6-3.3.1 |
| `rubygem-haml` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.0.6-3.3.1 |
| `rubygem-haml` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.0.6-3.3.1 |

Products: Debian Debian Linux, Haml Haml.

## How do I fix CVE-2017-1002201?

Upgrade haml to 5.0.0 or later.

## Is CVE-2017-1002201 being exploited?

There is no known exploitation of CVE-2017-1002201 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1002201 and fix it if it is affected.

What it is: CVE-2017-1002201 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 15 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1002201 in the wild and no public exploit code.

Affected packages and fixed versions:
- haml (RubyGems): affected all versions; fixed in 5.0.0
- haml (RubyGems): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1002201/ (Markdown: https://insights.sbomify.com/CVE-2017-1002201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1002201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1002201
- OSV: https://osv.dev/vulnerability/CVE-2017-1002201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1002201/
Summaries are generated and may contain mistakes; the official description above is the record.
