{"answers":{"affected":"2 open source packages ship an affected version, including webrick. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-10784 in the wild and no public exploit code.","fix":"Upgrade webrick to 1.4.0 or later.","what":"CVE-2017-10784 is a high-severity command injection vulnerability in Ruby-Lang Ruby, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-10784 and fix it if it is affected.\n\nWhat it is: CVE-2017-10784 is a high-severity command injection vulnerability in Ruby-Lang Ruby, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-10784 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- webrick (RubyGems): affected all versions; fixed in 1.4.0\n- webrick (RubyGems): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-10784/ (Markdown: https://insights.sbomify.com/CVE-2017-10784/index.md)","id":"CVE-2017-10784","markdown":"https://insights.sbomify.com/CVE-2017-10784/index.md","name":"CVE-2017-10784","record":{"aliases":["ALPINE-CVE-2017-10784","CLEANSTART-2026-MZ31215","GHSA-369m-2gv6-mw28","UBUNTU-CVE-2017-10784"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby WEBrick library","requires_auth":"none","summary":"Remote attackers can inject terminal escape sequences into WEBrick logs via crafted usernames, potentially executing arbitrary commands.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ruby","vendor":"ruby-lang"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WEBrick RCE Vulnerability","id":"CVE-2017-10784","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"ruby-lang:ruby","products":["ruby-lang:ruby"],"type":"command_injection","year":"2017"},"n_packages":2,"n_references":15,"next":{"headline":"Use after free in n/a","id":"CVE-2017-10788"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"webrick","purl":null,"source":"GHSA-369m-2gv6-mw28"},{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"webrick","purl":"pkg:gem/webrick","source":"GHSA-369m-2gv6-mw28"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-10783"},"products":["n/a"],"published":"2017-09-19","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2009-4124","kev_date_added":null,"published":"2009-12-11"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2022-28738","kev_date_added":null,"published":"2022-05-09"},{"cvss_score":9.8,"headline":"Weak cryptography in OpenSSL extension of Ruby (Git trunk)","id":"CVE-2011-4121","kev_date_added":null,"published":"2019-11-26"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2017-17790","kev_date_added":null,"published":"2017-12-20"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-11465","kev_date_added":null,"published":"2017-07-19"},{"cvss_score":9.8,"headline":"Memory corruption in Ruby","id":"CVE-2016-2336","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":9.8,"headline":"Code injection in Ruby","id":"CVE-2016-2337","kev_date_added":null,"published":"2017-01-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can inject terminal escape sequences into WEBrick logs via crafted usernames, potentially executing arbitrary commands.","url":"https://insights.sbomify.com/CVE-2017-10784/"}