{"answers":{"affected":"2 open source packages ship an affected version, including fluentd. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-10906 in the wild and no public exploit code.","fix":"Upgrade fluentd to 0.12.41 or later.","what":"CVE-2017-10906 is a critical command injection vulnerability in Redhat Openstack, published on 8 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-10906 and fix it if it is affected.\n\nWhat it is: CVE-2017-10906 is a critical command injection vulnerability in Redhat Openstack, published on 8 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-10906 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluentd (RubyGems): affected from 0.12.29; fixed in 0.12.41\n- fluentd (RubyGems): affected from 0.12.29; fixed in 0.12.41\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-10906/ (Markdown: https://insights.sbomify.com/CVE-2017-10906/index.md)","id":"CVE-2017-10906","markdown":"https://insights.sbomify.com/CVE-2017-10906/index.md","name":"CVE-2017-10906","record":{"aliases":["GHSA-5jrp-w8fr-mrww","RHSA-2018:2225"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Fluentd log collector","requires_auth":"none","summary":"Attackers can inject escape sequences to execute arbitrary commands on devices running Fluentd, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"fluentd","vendor":"fluentd"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.","ecosystems":["Red Hat:openstack-optools:13::el7","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Fluentd Escape Sequence Injection Vulnerability","id":"CVE-2017-10906","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"redhat:openstack","products":["redhat:openstack"],"type":"command_injection","year":"2017"},"n_packages":3,"n_references":4,"next":{"headline":"Path traversal in OneThird CMS","id":"CVE-2017-10907"},"packages":[{"ecosystem":"RubyGems","fixed":["0.12.41"],"introduced":["0.12.29"],"last_affected":[],"package":"fluentd","purl":null,"source":"GHSA-5jrp-w8fr-mrww"},{"ecosystem":"RubyGems","fixed":["0.12.41"],"introduced":["0.12.29"],"last_affected":[],"package":"fluentd","purl":"pkg:gem/fluentd","source":"GHSA-5jrp-w8fr-mrww"},{"ecosystem":"Red Hat:openstack-optools:13::el7","fixed":["0:0.12.41-1.el7"],"introduced":["0"],"last_affected":[],"package":"fluentd","purl":"pkg:rpm/redhat/fluentd","source":"RHSA-2018:2225"}],"prev":{"headline":"Other in Qt for Android","id":"CVE-2017-10905"},"products":["Fluentd"],"published":"2017-12-08","related":[{"cvss_score":9.8,"headline":"Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder","id":"CVE-2026-44024","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":8.8,"headline":"Fluent Fluentd and Fluent-ui use default password","id":"CVE-2020-21514","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":7.5,"headline":"Fluentd: Exposure of Sensitive Information via Monitor Agent API","id":"CVE-2026-44025","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.5,"headline":"Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`","id":"CVE-2026-44160","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.2,"headline":"Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`","id":"CVE-2026-44161","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":5.9,"headline":"ReDoS vulnerability in parser_apache2","id":"CVE-2021-41186","kev_date_added":null,"published":"2021-10-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Cloud Native Computing Foundation (CNCF)"]},"summary":"Attackers can inject escape sequences to execute arbitrary commands on devices running Fluentd, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/CVE-2017-10906/"}