# CVE-2017-10906: Fluentd Escape Sequence Injection Vulnerability

> Attackers can inject escape sequences to execute arbitrary commands on devices running Fluentd, requiring an upgrade to secure the system.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5jrp-w8fr-mrww, RHSA-2018:2225

## What is CVE-2017-10906?

CVE-2017-10906 is a critical command injection vulnerability in Redhat Openstack, published on 8 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

## Which versions are affected by CVE-2017-10906?

2 open source packages ship an affected version, including fluentd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluentd` | RubyGems | From 0.12.29 | 0.12.41 |
| `fluentd` | RubyGems | From 0.12.29 | 0.12.41 |
| `fluentd` | Red Hat:openstack-optools:13::el7 | All versions | 0:0.12.41-1.el7 |

Products: Fluentd Fluentd, Redhat Openstack.

## How do I fix CVE-2017-10906?

Upgrade fluentd to 0.12.41 or later.

## Is CVE-2017-10906 being exploited?

There is no known exploitation of CVE-2017-10906 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openstack

- [CVE-2026-44024](https://insights.sbomify.com/CVE-2026-44024/): Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder (critical 9.8)
- [CVE-2020-21514](https://insights.sbomify.com/CVE-2020-21514/): Fluent Fluentd and Fluent-ui use default password (high 8.8)
- [CVE-2026-44025](https://insights.sbomify.com/CVE-2026-44025/): Fluentd: Exposure of Sensitive Information via Monitor Agent API (high 7.5)
- [CVE-2026-44160](https://insights.sbomify.com/CVE-2026-44160/): Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` (high 7.5)
- [CVE-2026-44161](https://insights.sbomify.com/CVE-2026-44161/): Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-10906 and fix it if it is affected.

What it is: CVE-2017-10906 is a critical command injection vulnerability in Redhat Openstack, published on 8 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-10906 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluentd (RubyGems): affected from 0.12.29; fixed in 0.12.41
- fluentd (RubyGems): affected from 0.12.29; fixed in 0.12.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-10906/ (Markdown: https://insights.sbomify.com/CVE-2017-10906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-10906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-10906
- OSV: https://osv.dev/vulnerability/CVE-2017-10906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-10906/
Summaries are generated and may contain mistakes; the official description above is the record.
