{"answers":{"affected":"2 open source packages ship an affected version, including mqtt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-10910 in the wild and no public exploit code.","fix":"Upgrade mqtt to 2.15.0 or later.","what":"CVE-2017-10910 is a medium-severity denial of service vulnerability in MQTT.js. MQTT.js, published on 27 Dec 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-10910 and fix it if it is affected.\n\nWhat it is: CVE-2017-10910 is a medium-severity denial of service vulnerability in MQTT.js. MQTT.js, published on 27 Dec 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-10910 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mqtt (npm): affected from 2.0.0; fixed in 2.15.0\n- mqtt (npm): affected from 2.0.0; fixed in 2.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-10910/ (Markdown: https://insights.sbomify.com/CVE-2017-10910/index.md)","id":"CVE-2017-10910","markdown":"https://insights.sbomify.com/CVE-2017-10910/index.md","name":"CVE-2017-10910","record":{"aliases":["GHSA-h9mj-fghc-664w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MQTT JavaScript library","requires_auth":"low_privilege","summary":"An attacker can cause a denial-of-service condition in MQTT.js by exploiting improper handling of PUBLISH tickets.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"mqtt.js","vendor":"mqtt.js_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"MQTT.js 2.x.x prior to 2.15.0 issue in handling PUBLISH tickets may lead to an attacker causing a denial-of-service condition.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in mqtt","id":"CVE-2017-10910","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2017-10911"},"packages":[{"ecosystem":"npm","fixed":["2.15.0"],"introduced":["2.0.0"],"last_affected":[],"package":"mqtt","purl":null,"source":"GHSA-h9mj-fghc-664w"},{"ecosystem":"npm","fixed":["2.15.0"],"introduced":["2.0.0"],"last_affected":[],"package":"mqtt","purl":"pkg:npm/mqtt","source":"GHSA-h9mj-fghc-664w"}],"prev":{"headline":"Other in Music Center for PC","id":"CVE-2017-10909"},"products":["MQTT.js"],"published":"2017-12-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["MQTT.js."]},"summary":"An attacker can cause a denial-of-service condition in MQTT.js by exploiting improper handling of PUBLISH tickets.","url":"https://insights.sbomify.com/CVE-2017-10910/"}