# CVE-2017-10910: Denial of Service in mqtt

> An attacker can cause a denial-of-service condition in MQTT.js by exploiting improper handling of PUBLISH tickets.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-h9mj-fghc-664w

## What is CVE-2017-10910?

CVE-2017-10910 is a medium-severity denial of service vulnerability in MQTT.js. MQTT.js, published on 27 Dec 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MQTT.js 2.x.x prior to 2.15.0 issue in handling PUBLISH tickets may lead to an attacker causing a denial-of-service condition.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2017-10910?

2 open source packages ship an affected version, including mqtt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mqtt` | npm | From 2.0.0 | 2.15.0 |
| `mqtt` | npm | From 2.0.0 | 2.15.0 |

Products: Mqtt.js Project Mqtt.js.

## How do I fix CVE-2017-10910?

Upgrade mqtt to 2.15.0 or later.

## Is CVE-2017-10910 being exploited?

There is no known exploitation of CVE-2017-10910 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-10910 and fix it if it is affected.

What it is: CVE-2017-10910 is a medium-severity denial of service vulnerability in MQTT.js. MQTT.js, published on 27 Dec 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-10910 in the wild and no public exploit code.

Affected packages and fixed versions:
- mqtt (npm): affected from 2.0.0; fixed in 2.15.0
- mqtt (npm): affected from 2.0.0; fixed in 2.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-10910/ (Markdown: https://insights.sbomify.com/CVE-2017-10910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-10910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-10910
- OSV: https://osv.dev/vulnerability/CVE-2017-10910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-10910/
Summaries are generated and may contain mistakes; the official description above is the record.
