{"answers":{"affected":"It affects 5 products.","exploited":"Yes. Attackers have exploited CVE-2017-11292 in the wild since at least 3 Mar 2022.","fix":"Upgrade to a fixed version. US federal agencies must fix it by 24 Mar 2022.","what":"CVE-2017-11292 is a high-severity memory corruption vulnerability in Adobe Flash Player, published on 21 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-11292 and fix it if it is affected.\n\nWhat it is: CVE-2017-11292 is a high-severity memory corruption vulnerability in Adobe Flash Player, published on 21 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: Yes. Attackers have exploited CVE-2017-11292 in the wild since at least 3 Mar 2022.\n\nAffected product: Adobe Flash Player. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-11292/ (Markdown: https://insights.sbomify.com/CVE-2017-11292/index.md)","id":"CVE-2017-11292","markdown":"https://insights.sbomify.com/CVE-2017-11292/index.md","name":"CVE-2017-11292","record":{"aliases":["GHSA-f6x6-gf9m-8cc3","MGASA-2017-0377","RHSA-2017:2899","UBUNTU-CVE-2017-11292"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe Flash Player","requires_auth":"none","summary":"A type confusion vulnerability in Adobe Flash Player allows attackers to execute arbitrary code via crafted content.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"flash_player","vendor":"adobe"},{"product":"flash_player_desktop_runtime","vendor":"adobe"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"Adobe Flash Player version 27.0.0.159 and earlier has a flawed bytecode verification procedure, which allows for an untrusted value to be used in the calculation of an array index. This can lead to type confusion, and successful exploitation could lead to arbitrary code execution.","ecosystems":["Red Hat:rhel_extras:6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"exploited"},"has_fix":true,"headline":"Adobe Flash Player Type Confusion","id":"CVE-2017-11292","indexable":true,"kev":{"dateAdded":"2022-03-03","dueDate":"2022-03-24","knownRansomwareCampaignUse":"Unknown","product":"Flash Player","requiredAction":"The impacted product is end-of-life and should be disconnected if still in use.","vendorProject":"Adobe","vulnerabilityName":"Adobe Flash Player Type Confusion Vulnerability"},"kind":"cve","links":{"ecosystem":null,"product":"adobe:flash_player","products":["adobe:flash_player","adobe:flash_player_desktop_runtime","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"memory_corruption","year":"2017"},"n_packages":1,"n_references":5,"next":{"headline":"Memory corruption in Adobe Acrobat Reader 2017.012.20098 and earlier versions, 2017.011.30066 and earlier versions, 2015.006.30355 and earlier versions, 11.0.22 and earlier versions","id":"CVE-2017-11293"},"packages":[{"ecosystem":"Red Hat:rhel_extras:6","fixed":["0:27.0.0.170-1.el6_9"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2017:2899"}],"prev":{"headline":"Server-side request forgery in Adobe Connect 9.6.2 and earlier versions","id":"CVE-2017-11291"},"products":["Adobe Flash Player version 27.0.0.159 and earlier"],"published":"2017-10-21","related":[{"cvss_score":8.8,"headline":"Adobe Flash Player Use-After-Free","id":"CVE-2016-7892","kev_date_added":"2022-03-25","published":"2016-12-15"},{"cvss_score":8.8,"headline":"Adobe Flash Player Use-After-Free","id":"CVE-2016-7855","kev_date_added":"2022-03-03","published":"2016-11-01"},{"cvss_score":8.8,"headline":"Adobe Flash Player Integer Underflow Vulnerablity","id":"CVE-2014-0497","kev_date_added":"2024-09-17","published":"2014-02-05"},{"cvss_score":8.8,"headline":"Adobe Flash Player Incorrect Default Permissions","id":"CVE-2013-0643","kev_date_added":"2024-09-17","published":"2013-02-27"},{"cvss_score":8.8,"headline":"Adobe Flash Player Code Execution","id":"CVE-2013-0648","kev_date_added":"2024-09-17","published":"2013-02-27"},{"cvss_score":8.8,"headline":"Adobe Flash Player Integer Overflow","id":"CVE-2012-5054","kev_date_added":"2022-06-08","published":"2012-09-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["n/a"]},"summary":"A type confusion vulnerability in Adobe Flash Player allows attackers to execute arbitrary code via crafted content.","url":"https://insights.sbomify.com/CVE-2017-11292/"}