# CVE-2017-11424: PyJWT vulnerable to key confusion attacks

> Attackers can bypass JWT signature verification using PKCS1 PEM keys, allowing them to forge tokens and impersonate users.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** CVE-2017-12880, DEBIAN-CVE-2017-11424, DSA-3979-1, GHSA-r9jw-mwhq-wp62, PYSEC-2017-24, UBUNTU-CVE-2017-11424, USN-3407-1

## What is CVE-2017-11424?

CVE-2017-11424 is a high-severity vulnerability in Debian Debian Linux, published on 24 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PyJWT 1.5.0 and below the `invalid_strings` check in `HMACAlgorithm.prepare_key` does not account for all PEM encoded public keys. Specifically, the PKCS1 PEM encoded format would be allowed because it is prefaced with the string `-----BEGIN RSA PUBLIC KEY-----` which is not accounted for. This enables symmetric/asymmetric key confusion attacks against users using the PKCS1 PEM encoded public keys, which would allow an attacker to craft JWTs from scratch.

## Which versions are affected by CVE-2017-11424?

3 open source packages ship an affected version, including pyjwt. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyjwt` | PyPI | All versions | 1.5.1 |
| `pyjwt` | PyPI | All versions | 1.5.1 |
| `pyjwt` | PyPI | All versions | 1.5.1 |

Products: Debian Debian Linux, Pyjwt Project Pyjwt.

## How do I fix CVE-2017-11424?

Upgrade pyjwt to 1.5.1 or later.

## Is CVE-2017-11424 being exploited?

There is no known exploitation of CVE-2017-11424 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11424 and fix it if it is affected.

What it is: CVE-2017-11424 is a high-severity vulnerability in Debian Debian Linux, published on 24 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-11424 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyjwt (PyPI): affected all versions; fixed in 1.5.1
- pyjwt (PyPI): affected all versions; fixed in 1.5.1
- pyjwt (PyPI): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11424/ (Markdown: https://insights.sbomify.com/CVE-2017-11424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11424
- OSV: https://osv.dev/vulnerability/CVE-2017-11424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11424/
Summaries are generated and may contain mistakes; the official description above is the record.
