{"answers":{"affected":"3 open source packages ship an affected version, including python-saml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-11427 in the wild and no public exploit code.","fix":"Upgrade python-saml to 2.4.0 or later.","what":"CVE-2017-11427 is a high-severity authentication bypass vulnerability in OneLogin PythonSAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-11427 and fix it if it is affected.\n\nWhat it is: CVE-2017-11427 is a high-severity authentication bypass vulnerability in OneLogin PythonSAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-11427 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- python-saml (PyPI): affected all versions; fixed in 2.4.0\n- python-saml (PyPI): affected all versions; fixed in 2.4.0\n- python-saml (PyPI): affected all versions; fixed in 2.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-11427/ (Markdown: https://insights.sbomify.com/CVE-2017-11427/index.md)","id":"CVE-2017-11427","markdown":"https://insights.sbomify.com/CVE-2017-11427/index.md","name":"CVE-2017-11427","record":{"aliases":["GHSA-j8j8-348v-wfm3","PYSEC-2019-198","SUSE-SU-2021:0048-1","openSUSE-SU-2024:11262-1","openSUSE-SU-2024:14159-1","openSUSE-SU-2026:12034-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python SAML library","requires_auth":"low_privilege","summary":"Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting applications using OneLogin PythonSAML.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"duo","cpe":[{"product":"pythonsaml","vendor":"onelogin"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"OneLogin PythonSAML 2.3.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.","ecosystems":["PyPI","SUSE:Enterprise Storage 6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2018-03-03","github_poc":1,"max_poc_stars":12,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-03-03T00:29:22Z","kind":"github_poc","ref":"https://github.com/CHYbeta/CVE-2017-11427-DEMO","stars":12,"title":"The Demo for CVE-2017-11427"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11427","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2017"},"n_packages":11,"n_references":2,"next":{"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11428"},"packages":[{"ecosystem":"PyPI","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"python-saml","purl":null,"source":"GHSA-j8j8-348v-wfm3"},{"ecosystem":"PyPI","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"python-saml","purl":"pkg:pypi/python-saml","source":"GHSA-j8j8-348v-wfm3"},{"ecosystem":"PyPI","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"python-saml","purl":"pkg:pypi/python-saml","source":"PYSEC-2019-198"},{"ecosystem":"SUSE:Enterprise Storage 6","fixed":["0.6.0-1.5.1"],"introduced":["0"],"last_affected":[],"package":"python-defusedxml","purl":"pkg:rpm/suse/python-defusedxml\u0026distro=SUSE%20Enterprise%20Storage%206","source":"SUSE-SU-2021:0048-1"},{"ecosystem":"SUSE:Enterprise Storage 6","fixed":["0.3.12-1.5.1"],"introduced":["0"],"last_affected":[],"package":"python-freezegun","purl":"pkg:rpm/suse/python-freezegun\u0026distro=SUSE%20Enterprise%20Storage%206","source":"SUSE-SU-2021:0048-1"},{"ecosystem":"SUSE:Enterprise Storage 6","fixed":["0.6.0-1.3.2"],"introduced":["0"],"last_affected":[],"package":"python-isodate","purl":"pkg:rpm/suse/python-isodate\u0026distro=SUSE%20Enterprise%20Storage%206","source":"SUSE-SU-2021:0048-1"},{"ecosystem":"SUSE:Enterprise Storage 6","fixed":["1.5.1-1.5.1"],"introduced":["0"],"last_affected":[],"package":"python-pkgconfig","purl":"pkg:rpm/suse/python-pkgconfig\u0026distro=SUSE%20Enterprise%20Storage%206","source":"SUSE-SU-2021:0048-1"},{"ecosystem":"SUSE:Enterprise Storage 6","fixed":["1.9.0-1.5.2"],"introduced":["0"],"last_affected":[],"package":"python-python3-saml","purl":"pkg:rpm/suse/python-python3-saml\u0026distro=SUSE%20Enterprise%20Storage%206","source":"SUSE-SU-2021:0048-1"},{"ecosystem":"SUSE:Enterprise Storage 6","fixed":["1.3.6-1.5.1"],"introduced":["0"],"last_affected":[],"package":"python-xmlsec","purl":"pkg:rpm/suse/python-xmlsec\u0026distro=SUSE%20Enterprise%20Storage%206","source":"SUSE-SU-2021:0048-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.15.0-2.3"],"introduced":["0"],"last_affected":[],"package":"python-python3-saml","purl":"pkg:rpm/opensuse/python-python3-saml\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14159-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.16.0-2.4"],"introduced":["0"],"last_affected":[],"package":"python-python3-saml","purl":"pkg:rpm/opensuse/python-python3-saml\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12034-1"}],"prev":{"headline":"PyJWT vulnerable to key confusion attacks","id":"CVE-2017-11424"},"products":["PythonSAML"],"published":"2019-04-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["OneLogin"]},"summary":"Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting applications using OneLogin PythonSAML.","url":"https://insights.sbomify.com/CVE-2017-11427/"}