# CVE-2017-11427: Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal

> Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting applications using OneLogin PythonSAML.

- **Severity:** High 7.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j8j8-348v-wfm3, PYSEC-2019-198, SUSE-SU-2021:0048-1, openSUSE-SU-2024:11262-1, openSUSE-SU-2024:14159-1, openSUSE-SU-2026:12034-1

## What is CVE-2017-11427?

CVE-2017-11427 is a high-severity authentication bypass vulnerability in OneLogin PythonSAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OneLogin PythonSAML 2.3.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-11427?

3 open source packages ship an affected version, including python-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-saml` | PyPI | All versions | 2.4.0 |
| `python-saml` | PyPI | All versions | 2.4.0 |
| `python-saml` | PyPI | All versions | 2.4.0 |
| `python-defusedxml` | SUSE:Enterprise Storage 6 | All versions | 0.6.0-1.5.1 |
| `python-freezegun` | SUSE:Enterprise Storage 6 | All versions | 0.3.12-1.5.1 |
| `python-isodate` | SUSE:Enterprise Storage 6 | All versions | 0.6.0-1.3.2 |
| `python-pkgconfig` | SUSE:Enterprise Storage 6 | All versions | 1.5.1-1.5.1 |
| `python-python3-saml` | SUSE:Enterprise Storage 6 | All versions | 1.9.0-1.5.2 |
| `python-xmlsec` | SUSE:Enterprise Storage 6 | All versions | 1.3.6-1.5.1 |
| `python-python3-saml` | openSUSE:Tumbleweed | All versions | 1.15.0-2.3 |
| `python-python3-saml` | openSUSE:Tumbleweed | All versions | 1.16.0-2.4 |

Products: Onelogin Pythonsaml.

## How do I fix CVE-2017-11427?

Upgrade python-saml to 2.4.0 or later.

## Is CVE-2017-11427 being exploited?

There is no known exploitation of CVE-2017-11427 in the wild and no public exploit code.

Public exploit code:

- The Demo for CVE-2017-11427 (github_poc): https://github.com/CHYbeta/CVE-2017-11427-DEMO

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11427 and fix it if it is affected.

What it is: CVE-2017-11427 is a high-severity authentication bypass vulnerability in OneLogin PythonSAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-11427 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-saml (PyPI): affected all versions; fixed in 2.4.0
- python-saml (PyPI): affected all versions; fixed in 2.4.0
- python-saml (PyPI): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11427/ (Markdown: https://insights.sbomify.com/CVE-2017-11427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11427
- OSV: https://osv.dev/vulnerability/CVE-2017-11427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11427/
Summaries are generated and may contain mistakes; the official description above is the record.
