# CVE-2017-11428: Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal

> Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting Ruby-SAML library users.

- **Severity:** High 7.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-11428, GHSA-x2fr-v8wf-8wwv, UBUNTU-CVE-2017-11428

## What is CVE-2017-11428?

CVE-2017-11428 is a high-severity authentication bypass vulnerability in OneLogin Ruby-SAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OneLogin Ruby-SAML 1.6.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-11428?

2 open source packages ship an affected version, including ruby-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby-saml` | RubyGems | All versions | 1.7.0 |
| `ruby-saml` | RubyGems | All versions | 1.7.0 |

Products: Onelogin Ruby-Saml.

## How do I fix CVE-2017-11428?

Upgrade ruby-saml to 1.7.0 or later.

## Is CVE-2017-11428 being exploited?

There is no known exploitation of CVE-2017-11428 in the wild and no public exploit code.

## Other vulnerabilities in OneLogin Ruby-SAML

- [CVE-2015-20108](https://insights.sbomify.com/CVE-2015-20108/): ruby-saml vulnerable to XPath injection (critical 9.8)
- [CVE-2025-66567](https://insights.sbomify.com/CVE-2025-66567/): ruby-saml has a SAML authentication bypass due to namespace handling (parser differential) (critical 9.3)
- [CVE-2025-66568](https://insights.sbomify.com/CVE-2025-66568/): ruby-saml Libxml2 Canonicalization errors can bypass Digest/Signature validation (critical 9.3)
- [CVE-2016-5697](https://insights.sbomify.com/CVE-2016-5697/): Ruby-saml allows attackers to perform XML signature wrapping attacks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11428 and fix it if it is affected.

What it is: CVE-2017-11428 is a high-severity authentication bypass vulnerability in OneLogin Ruby-SAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-11428 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby-saml (RubyGems): affected all versions; fixed in 1.7.0
- ruby-saml (RubyGems): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11428/ (Markdown: https://insights.sbomify.com/CVE-2017-11428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11428
- OSV: https://osv.dev/vulnerability/CVE-2017-11428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11428/
Summaries are generated and may contain mistakes; the official description above is the record.
