CVE-2017-11429 Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal
Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting Clever saml2-js users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-11429?
CVE-2017-11429 is a high-severity authentication bypass vulnerability in Clever saml2-js, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Clever saml2-js 2.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
Weakness: CWE-287
Which versions are affected by CVE-2017-11429?
4 open source packages ship an affected version, including saml2-js. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
saml2-js npm | All versions | 1.12.4 |
saml2-js npm | All versions | 1.12.4 |
saml2-js npm | From 2.0.0 | 2.0.2 |
saml2-js npm | From 2.0.0 | 2.0.2 |
Products include Clever Saml2-Js.
How do I fix CVE-2017-11429?
Upgrade saml2-js to a fixed version for your release line: 1.12.4 or 2.0.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2017-11429 being exploited?
There is no known exploitation of CVE-2017-11429 in the wild and no public exploit code.
Sources
Also known as GHSA-5p5w-j3g7-w4wv.