{"answers":{"affected":"4 open source packages ship an affected version, including saml2-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-11429 in the wild and no public exploit code.","fix":"Upgrade saml2-js to a fixed version for your release line: 1.12.4 or 2.0.2.","what":"CVE-2017-11429 is a high-severity authentication bypass vulnerability in Clever saml2-js, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-11429 and fix it if it is affected.\n\nWhat it is: CVE-2017-11429 is a high-severity authentication bypass vulnerability in Clever saml2-js, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-11429 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- saml2-js (npm): affected all versions; fixed in 1.12.4\n- saml2-js (npm): affected all versions; fixed in 1.12.4\n- saml2-js (npm): affected from 2.0.0; fixed in 2.0.2\n- saml2-js (npm): affected from 2.0.0; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-11429/ (Markdown: https://insights.sbomify.com/CVE-2017-11429/index.md)","id":"CVE-2017-11429","markdown":"https://insights.sbomify.com/CVE-2017-11429/index.md","name":"CVE-2017-11429","record":{"aliases":["GHSA-5p5w-j3g7-w4wv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SAML authentication library","requires_auth":"low_privilege","summary":"Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting Clever saml2-js users.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"duo","cpe":[{"product":"saml2-js","vendor":"clever"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Clever saml2-js 2.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11429","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2017"},"n_packages":4,"n_references":2,"next":{"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11430"},"packages":[{"ecosystem":"npm","fixed":["1.12.4"],"introduced":["0"],"last_affected":[],"package":"saml2-js","purl":null,"source":"GHSA-5p5w-j3g7-w4wv"},{"ecosystem":"npm","fixed":["1.12.4"],"introduced":["0"],"last_affected":[],"package":"saml2-js","purl":"pkg:npm/saml2-js","source":"GHSA-5p5w-j3g7-w4wv"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"saml2-js","purl":null,"source":"GHSA-5p5w-j3g7-w4wv"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"saml2-js","purl":"pkg:npm/saml2-js","source":"GHSA-5p5w-j3g7-w4wv"}],"prev":{"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11428"},"products":["saml2-js"],"published":"2019-04-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Clever"]},"summary":"Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting Clever saml2-js users.","url":"https://insights.sbomify.com/CVE-2017-11429/"}