# CVE-2017-11429: Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal

> Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting Clever saml2-js users.

- **Severity:** High 7.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5p5w-j3g7-w4wv

## What is CVE-2017-11429?

CVE-2017-11429 is a high-severity authentication bypass vulnerability in Clever saml2-js, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Clever saml2-js 2.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-11429?

4 open source packages ship an affected version, including saml2-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `saml2-js` | npm | All versions | 1.12.4 |
| `saml2-js` | npm | All versions | 1.12.4 |
| `saml2-js` | npm | From 2.0.0 | 2.0.2 |
| `saml2-js` | npm | From 2.0.0 | 2.0.2 |

Products: Clever Saml2-Js.

## How do I fix CVE-2017-11429?

Upgrade saml2-js to a fixed version for your release line: 1.12.4 or 2.0.2.

## Is CVE-2017-11429 being exploited?

There is no known exploitation of CVE-2017-11429 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11429 and fix it if it is affected.

What it is: CVE-2017-11429 is a high-severity authentication bypass vulnerability in Clever saml2-js, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-11429 in the wild and no public exploit code.

Affected packages and fixed versions:
- saml2-js (npm): affected all versions; fixed in 1.12.4
- saml2-js (npm): affected all versions; fixed in 1.12.4
- saml2-js (npm): affected from 2.0.0; fixed in 2.0.2
- saml2-js (npm): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11429/ (Markdown: https://insights.sbomify.com/CVE-2017-11429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11429
- OSV: https://osv.dev/vulnerability/CVE-2017-11429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11429/
Summaries are generated and may contain mistakes; the official description above is the record.
