{"answers":{"affected":"2 open source packages ship an affected version, including omniauth-saml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-11430 in the wild and no public exploit code.","fix":"Upgrade omniauth-saml to 1.10.0 or later.","what":"CVE-2017-11430 is a high-severity authentication bypass vulnerability in OmniAuth OmnitAuth-SAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-11430 and fix it if it is affected.\n\nWhat it is: CVE-2017-11430 is a high-severity authentication bypass vulnerability in OmniAuth OmnitAuth-SAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-11430 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omniauth-saml (RubyGems): affected all versions; fixed in 1.10.0\n- omniauth-saml (RubyGems): affected all versions; fixed in 1.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-11430/ (Markdown: https://insights.sbomify.com/CVE-2017-11430/index.md)","id":"CVE-2017-11430","markdown":"https://insights.sbomify.com/CVE-2017-11430/index.md","name":"CVE-2017-11430","record":{"aliases":["GHSA-94hm-8q65-rmxm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SAML library","requires_auth":"low_privilege","summary":"Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting Ruby applications using OmniAuth-SAML.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"duo","cpe":[{"product":"omniauth_saml","vendor":"omniauth"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"OmniAuth OmnitAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11430","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-11434"},"packages":[{"ecosystem":"RubyGems","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"omniauth-saml","purl":null,"source":"GHSA-94hm-8q65-rmxm"},{"ecosystem":"RubyGems","fixed":["1.10.0"],"introduced":["0"],"last_affected":[],"package":"omniauth-saml","purl":"pkg:gem/omniauth-saml","source":"GHSA-94hm-8q65-rmxm"}],"prev":{"headline":"Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal","id":"CVE-2017-11429"},"products":["OmnitAuth-SAML"],"published":"2019-04-17","related":[{"cvss_score":7.7,"headline":"ruby-saml vulnerable to Remote Denial of Service (DoS) with compressed SAML responses","id":"CVE-2025-25293","kev_date_added":null,"published":"2025-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["OmniAuth"]},"summary":"Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting Ruby applications using OmniAuth-SAML.","url":"https://insights.sbomify.com/CVE-2017-11430/"}