# CVE-2017-11430: Multiple SAML libraries may allow authentication bypass via incorrect XML canonicalization and DOM traversal

> Attackers can bypass SAML authentication by manipulating XML data without invalidating signatures, affecting Ruby applications using OmniAuth-SAML.

- **Severity:** High 7.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-94hm-8q65-rmxm

## What is CVE-2017-11430?

CVE-2017-11430 is a high-severity authentication bypass vulnerability in OmniAuth OmnitAuth-SAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OmniAuth OmnitAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-11430?

2 open source packages ship an affected version, including omniauth-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omniauth-saml` | RubyGems | All versions | 1.10.0 |
| `omniauth-saml` | RubyGems | All versions | 1.10.0 |

Products: Omniauth Omniauth Saml.

## How do I fix CVE-2017-11430?

Upgrade omniauth-saml to 1.10.0 or later.

## Is CVE-2017-11430 being exploited?

There is no known exploitation of CVE-2017-11430 in the wild and no public exploit code.

## Other vulnerabilities in OmniAuth OmnitAuth-SAML

- [CVE-2025-25293](https://insights.sbomify.com/CVE-2025-25293/): ruby-saml vulnerable to Remote Denial of Service (DoS) with compressed SAML responses (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11430 and fix it if it is affected.

What it is: CVE-2017-11430 is a high-severity authentication bypass vulnerability in OmniAuth OmnitAuth-SAML, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-11430 in the wild and no public exploit code.

Affected packages and fixed versions:
- omniauth-saml (RubyGems): affected all versions; fixed in 1.10.0
- omniauth-saml (RubyGems): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11430/ (Markdown: https://insights.sbomify.com/CVE-2017-11430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11430
- OSV: https://osv.dev/vulnerability/CVE-2017-11430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11430/
Summaries are generated and may contain mistakes; the official description above is the record.
