# CVE-2017-11467: OrientDB vulnerable to Improper Privilage Management leading to arbitrary command injection

> Remote attackers can execute arbitrary OS commands by bypassing privilege checks in OrientDB query clauses.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xm6r-4466-mr74

## What is CVE-2017-11467?

CVE-2017-11467 is a critical vulnerability in n/a, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2017-11467?

2 open source packages ship an affected version, including com.orientechnologies:orientdb-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.orientechnologies:orientdb-core` | Maven | All versions | 2.2.23 |
| `com.orientechnologies:orientdb-core` | Maven | All versions | 2.2.23 |

Products: Orientdb Orientdb.

## How do I fix CVE-2017-11467?

Upgrade com.orientechnologies:orientdb-core to 2.2.23 or later.

## Is CVE-2017-11467 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-11467 exists.

Public exploit code:

- OrientDB - Code Execution (exploitdb)
- OrientDB 2.2.x Remote Code Execution (metasploit)

## Other vulnerabilities in n/a

- [CVE-2015-2912](https://insights.sbomify.com/CVE-2015-2912/): OrientDB-Server vulnerable to Cross-Site Request Forgery (high 8.8)
- [CVE-2015-2918](https://insights.sbomify.com/CVE-2015-2918/): OrientDB Studio web management interface is vulnerable to clickjacking attacks (medium 6.1)
- [CVE-2015-2913](https://insights.sbomify.com/CVE-2015-2913/): OrientDB Server Community Edition uses insufficiently random values to generate session IDs (medium 5.9)
- [CVE-2019-25447](https://insights.sbomify.com/CVE-2019-25447/): OrientDB 3.0.17 Cross-Site Request Forgery (medium 5.3)
- [CVE-2019-25448](https://insights.sbomify.com/CVE-2019-25448/): OrientDB 3.0.17 Stored Cross-Site Scripting via User Creation (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11467 and fix it if it is affected.

What it is: CVE-2017-11467 is a critical vulnerability in n/a, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-11467 exists.

Affected packages and fixed versions:
- com.orientechnologies:orientdb-core (Maven): affected all versions; fixed in 2.2.23
- com.orientechnologies:orientdb-core (Maven): affected all versions; fixed in 2.2.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11467/ (Markdown: https://insights.sbomify.com/CVE-2017-11467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11467
- OSV: https://osv.dev/vulnerability/CVE-2017-11467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11467/
Summaries are generated and may contain mistakes; the official description above is the record.
