CVE-2017-11468 Docker Registry has Allocation of Resources Without Limits or Throttling
Remote attackers can cause denial of service via memory consumption in Docker Registry by exploiting the manifest endpoint.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-11468?
CVE-2017-11468 is a high-severity denial of service vulnerability in Redhat Enterprise Linux Server, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Docker Registry before 2.6.2 in Docker Distribution does not properly restrict the amount of content accepted from a user, which allows remote attackers to cause a denial of service (memory consumption) via the manifest endpoint.
Weakness: CWE-770
Which versions are affected by CVE-2017-11468?
3 open source packages ship an affected version, including github.com/docker/distribution. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/docker/distribution Go | All versions | 2.7.0-rc.0 |
github.com/docker/distribution Go | All versions | 2.7.0-rc.0 |
github.com/docker/distribution Go | All versions | 2.7.0-rc.0+incompatible |
Linux distribution packages (5)
docker-distribution Red Hat:rhel_extras_other:7 | All versions | 0:2.6.2-1.git48294d9.el7 |
docker-distribution SUSE:Linux Enterprise Module for Containers 12 | All versions | 2.6.2-13.6.1 |
docker-distribution SUSE:Package Hub 15 SP2 | All versions | 2.7.1-bp152.4.3.1 |
distribution-registry openSUSE:Tumbleweed | All versions | 2.8.1-1.1 |
docker-distribution-registry openSUSE:Tumbleweed | All versions | 2.7.1-7.2 |
Products include Docker Docker Registry, Redhat Enterprise Linux Server.
How do I fix CVE-2017-11468?
Upgrade github.com/docker/distribution to a fixed version for your release line: 2.7.0-rc.0 or 2.7.0-rc.0+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-11468 being exploited?
There is no known exploitation of CVE-2017-11468 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2017-11468, GHSA-h62f-wm92-2cmw, GO-2021-0072, RHSA-2017:2603, SUSE-SU-2018:0865-1, UBUNTU-CVE-2017-11468 and 3 more.