{"answers":{"affected":"5 open source packages ship an affected version, including github.com/elastic/beats. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-11480 in the wild and no public exploit code.","fix":"Upgrade github.com/elastic/beats to a fixed version for your release line: 5.6.4, 6.1.0+incompatible or 6.0.0.","what":"CVE-2017-11480 is a high-severity denial of service vulnerability in Elastic Packetbeat, published on 8 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-11480 and fix it if it is affected.\n\nWhat it is: CVE-2017-11480 is a high-severity denial of service vulnerability in Elastic Packetbeat, published on 8 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-11480 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/elastic/beats (Go): affected all versions; fixed in 5.6.4\n- github.com/elastic/beats (Go): affected all versions; fixed in 5.6.4\n- github.com/elastic/beats (Go): affected all versions; fixed in 6.1.0+incompatible\n- github.com/elastic/beats (Go): affected from 6.0.0-alpha1; fixed in 6.0.0\n- github.com/elastic/beats (Go): affected from 6.0.0-alpha1; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-11480/ (Markdown: https://insights.sbomify.com/CVE-2017-11480/index.md)","id":"CVE-2017-11480","markdown":"https://insights.sbomify.com/CVE-2017-11480/index.md","name":"CVE-2017-11480","record":{"aliases":["GHSA-9q3g-m353-cp4p","GO-2022-0643"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Network monitoring tool","requires_auth":"none","summary":"Attackers can cause Packetbeat to stop logging PostgreSQL traffic by sending arbitrary network data to the monitored port.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"packetbeat","vendor":"elasticsearch"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in Packetbeat","id":"CVE-2017-11480","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":5,"n_references":1,"next":{"headline":"Cross-site scripting in Kibana","id":"CVE-2017-11481"},"packages":[{"ecosystem":"Go","fixed":["5.6.4"],"introduced":["0"],"last_affected":[],"package":"github.com/elastic/beats","purl":null,"source":"GHSA-9q3g-m353-cp4p"},{"ecosystem":"Go","fixed":["5.6.4"],"introduced":["0"],"last_affected":[],"package":"github.com/elastic/beats","purl":"pkg:golang/github.com/elastic/beats","source":"GHSA-9q3g-m353-cp4p"},{"ecosystem":"Go","fixed":["6.1.0+incompatible"],"introduced":["0"],"last_affected":[],"package":"github.com/elastic/beats","purl":"pkg:golang/github.com/elastic/beats","source":"GO-2022-0643"},{"ecosystem":"Go","fixed":["6.0.0"],"introduced":["6.0.0-alpha1"],"last_affected":[],"package":"github.com/elastic/beats","purl":null,"source":"GHSA-9q3g-m353-cp4p"},{"ecosystem":"Go","fixed":["6.0.0"],"introduced":["6.0.0-alpha1"],"last_affected":[],"package":"github.com/elastic/beats","purl":"pkg:golang/github.com/elastic/beats","source":"GHSA-9q3g-m353-cp4p"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-11479"},"products":["Packetbeat"],"published":"2017-12-08","related":[{"cvss_score":6.5,"headline":"Packetbeat Improper Bounds Check","id":"CVE-2025-68381","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":6.5,"headline":"Packetbeat Out-of-bounds Read","id":"CVE-2025-68382","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":5.7,"headline":"Improper Validation of Array Index in Packetbeat Leading to Denial of Service","id":"CVE-2026-26933","kev_date_added":null,"published":"2026-03-19"},{"cvss_score":5.7,"headline":"Improper Validation of Array Index in Packetbeat Leading to Denial of Service","id":"CVE-2026-26932","kev_date_added":null,"published":"2026-02-26"},{"cvss_score":5.3,"headline":"Elasticsearch Packetbeat has Excessive Allocation of Memory and CPU via Malicious IPv4 Fragments","id":"CVE-2025-68388","kev_date_added":null,"published":"2025-12-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Elastic"]},"summary":"Attackers can cause Packetbeat to stop logging PostgreSQL traffic by sending arbitrary network data to the monitored port.","url":"https://insights.sbomify.com/CVE-2017-11480/"}