# CVE-2017-11480: Denial of Service in Packetbeat

> Attackers can cause Packetbeat to stop logging PostgreSQL traffic by sending arbitrary network data to the monitored port.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9q3g-m353-cp4p, GO-2022-0643

## What is CVE-2017-11480?

CVE-2017-11480 is a high-severity denial of service vulnerability in Elastic Packetbeat, published on 8 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2017-11480?

5 open source packages ship an affected version, including github.com/elastic/beats. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/elastic/beats` | Go | All versions | 5.6.4 |
| `github.com/elastic/beats` | Go | All versions | 5.6.4 |
| `github.com/elastic/beats` | Go | All versions | 6.1.0+incompatible |
| `github.com/elastic/beats` | Go | From 6.0.0-alpha1 | 6.0.0 |
| `github.com/elastic/beats` | Go | From 6.0.0-alpha1 | 6.0.0 |

Products: Elasticsearch Packetbeat.

## How do I fix CVE-2017-11480?

Upgrade github.com/elastic/beats to a fixed version for your release line: 5.6.4, 6.1.0+incompatible or 6.0.0.

## Is CVE-2017-11480 being exploited?

There is no known exploitation of CVE-2017-11480 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Packetbeat

- [CVE-2025-68381](https://insights.sbomify.com/CVE-2025-68381/): Packetbeat Improper Bounds Check (medium 6.5)
- [CVE-2025-68382](https://insights.sbomify.com/CVE-2025-68382/): Packetbeat Out-of-bounds Read (medium 6.5)
- [CVE-2026-26933](https://insights.sbomify.com/CVE-2026-26933/): Improper Validation of Array Index in Packetbeat Leading to Denial of Service (medium 5.7)
- [CVE-2026-26932](https://insights.sbomify.com/CVE-2026-26932/): Improper Validation of Array Index in Packetbeat Leading to Denial of Service (medium 5.7)
- [CVE-2025-68388](https://insights.sbomify.com/CVE-2025-68388/): Elasticsearch Packetbeat has Excessive Allocation of Memory and CPU via Malicious IPv4 Fragments (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11480 and fix it if it is affected.

What it is: CVE-2017-11480 is a high-severity denial of service vulnerability in Elastic Packetbeat, published on 8 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-11480 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/elastic/beats (Go): affected all versions; fixed in 5.6.4
- github.com/elastic/beats (Go): affected all versions; fixed in 5.6.4
- github.com/elastic/beats (Go): affected all versions; fixed in 6.1.0+incompatible
- github.com/elastic/beats (Go): affected from 6.0.0-alpha1; fixed in 6.0.0
- github.com/elastic/beats (Go): affected from 6.0.0-alpha1; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11480/ (Markdown: https://insights.sbomify.com/CVE-2017-11480/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11480
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11480
- OSV: https://osv.dev/vulnerability/CVE-2017-11480

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11480/
Summaries are generated and may contain mistakes; the official description above is the record.
