# CVE-2017-11503: Cross-site scripting in PHPMailer

> Cross-site scripting vulnerability in PHPMailer allows attackers to inject malicious scripts via email address fields in the code generator.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-11503, GHSA-58mj-pw57-4vm2, MGASA-2017-0257, UBUNTU-CVE-2017-11503, USN-5956-2

## What is CVE-2017-11503?

CVE-2017-11503 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PHPMailer 5.2.23 has XSS in the "From Email Address" and "To Email Address" fields of code_generator.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-11503?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.24 |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.24 |

Products: Phpmailer Project Phpmailer.

## How do I fix CVE-2017-11503?

Upgrade phpmailer/phpmailer to 5.2.24 or later.

## Is CVE-2017-11503 being exploited?

There is no known exploitation of CVE-2017-11503 in the wild and no public exploit code.

Public exploit code:

- (https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-11503 (github_poc): https://github.com/wizardafric/download

## Other vulnerabilities in n/a

- [CVE-2020-36326](https://insights.sbomify.com/CVE-2020-36326/): Object injection in PHPMailer/PHPMailer (critical 9.8)
- [CVE-2017-5223](https://insights.sbomify.com/CVE-2017-5223/): Local file disclosure in PHPMailer (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11503 and fix it if it is affected.

What it is: CVE-2017-11503 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-11503 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.24
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11503/ (Markdown: https://insights.sbomify.com/CVE-2017-11503/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11503
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11503
- OSV: https://osv.dev/vulnerability/CVE-2017-11503

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11503/
Summaries are generated and may contain mistakes; the official description above is the record.
