# CVE-2017-11893: ChakraCore vulnerable to remote code execution

> An attacker can execute arbitrary code in the context of the current user via a memory corruption flaw in the ChakraCore scripting engine.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Dec 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-c6r3-ghjw-hgrj

## What is CVE-2017-11893?

CVE-2017-11893 is a high-severity memory corruption vulnerability in Microsoft Chakracore, published on 12 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ChakraCore and Microsoft Edge in Windows 10 1511, 1607, 1703, 1709, and Windows Server 2016 allows an attacker to execute arbitrary code in the context of the current user, due to how the scripting engine handles objects in memory, aka "Scripting Engine Memory Corruption Vulnerability". This CVE ID is unique from CVE-2017-11886, CVE-2017-11889, CVE-2017-11890, CVE-2017-11894, CVE-2017-11895, CVE-2017-11901, CVE-2017-11903, CVE-2017-11905, CVE-2017-11907, CVE-2017-11908, CVE-2017-11909, CVE-2017-11910, CVE-2017-11911, CVE-2017-11912, CVE-2017-11913, CVE-2017-11914, CVE-2017-11916, CVE-2017-11918, and CVE-2017-11930.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2017-11893?

2 open source packages ship an affected version, including Microsoft.ChakraCore. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.ChakraCore` | NuGet | All versions | 1.7.5 |
| `Microsoft.ChakraCore` | NuGet | All versions | 1.7.5 |

Products: Microsoft Chakracore, Microsoft Edge.

## How do I fix CVE-2017-11893?

Upgrade Microsoft.ChakraCore to 1.7.5 or later.

## Is CVE-2017-11893 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-11893 exists.

Public exploit code:

- Microsoft Edge Chakra JIT - Op_MaxInAnArray and Op_MinInAnArray can Explicitly call User-Defined JavaScript Functions (exploitdb)

## Other vulnerabilities in Microsoft Chakracore

- [CVE-2018-8298](https://insights.sbomify.com/CVE-2018-8298/): ChakraCore Scripting Engine Type Confusion (high 7.5, exploited in the wild)
- [CVE-2020-0878](https://insights.sbomify.com/CVE-2020-0878/): Microsoft Edge and Internet Explorer Memory Corruption (medium 4.2, exploited in the wild)
- [CVE-2018-8500](https://insights.sbomify.com/CVE-2018-8500/): ChakraCore RCE Vulnerability (critical 9.8)
- [CVE-2017-11767](https://insights.sbomify.com/CVE-2017-11767/): ChakraCore vulnerable to privilege escalation (critical 9.8)
- [CVE-2017-8658](https://insights.sbomify.com/CVE-2017-8658/): ChakraCore RCE Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-11893 and fix it if it is affected.

What it is: CVE-2017-11893 is a high-severity memory corruption vulnerability in Microsoft Chakracore, published on 12 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-11893 exists.

Affected packages and fixed versions:
- Microsoft.ChakraCore (NuGet): affected all versions; fixed in 1.7.5
- Microsoft.ChakraCore (NuGet): affected all versions; fixed in 1.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-11893/ (Markdown: https://insights.sbomify.com/CVE-2017-11893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-11893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-11893
- OSV: https://osv.dev/vulnerability/CVE-2017-11893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-11893/
Summaries are generated and may contain mistakes; the official description above is the record.
