# CVE-2017-12097: delayed_job_web Cross-site Scripting vulnerability

> An attacker can execute arbitrary JavaScript in a victim's browser via a crafted URL in the delayed_job_web gem, requiring user interaction.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-w7q9-xr2x-wh7x

## What is CVE-2017-12097?

CVE-2017-12097 is a medium-severity cross-site scripting vulnerability in Talos delayed_job_web rails gem, published on 19 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An exploitable cross site scripting (XSS) vulnerability exists in the filter functionality of the delayed_job_web rails gem version 1.4. A specially crafted URL can cause an XSS flaw resulting in an attacker being able to execute arbitrary javascript on the victim's browser. An attacker can phish an authenticated user to trigger this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-12097?

2 open source packages ship an affected version, including delayed_job_web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `delayed_job_web` | RubyGems | From 1.2.9 | 1.4.2 |
| `delayed_job_web` | RubyGems | From 1.2.9 | 1.4.2 |

Products: Delayed Job Web Project Delayed Job Web.

## How do I fix CVE-2017-12097?

Upgrade delayed_job_web to 1.4.2 or later.

## Is CVE-2017-12097 being exploited?

There is no known exploitation of CVE-2017-12097 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12097 and fix it if it is affected.

What it is: CVE-2017-12097 is a medium-severity cross-site scripting vulnerability in Talos delayed_job_web rails gem, published on 19 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12097 in the wild and no public exploit code.

Affected packages and fixed versions:
- delayed_job_web (RubyGems): affected from 1.2.9; fixed in 1.4.2
- delayed_job_web (RubyGems): affected from 1.2.9; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12097/ (Markdown: https://insights.sbomify.com/CVE-2017-12097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12097
- OSV: https://osv.dev/vulnerability/CVE-2017-12097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12097/
Summaries are generated and may contain mistakes; the official description above is the record.
