# CVE-2017-12098: rails_admin ruby gem XSS

> An attacker can execute arbitrary JavaScript in a victim's browser via a crafted URL in the Rails Admin gem's filter functionality.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pxr8-w3jq-rcwj, UBUNTU-CVE-2017-12098

## What is CVE-2017-12098?

CVE-2017-12098 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An exploitable cross site scripting (XSS) vulnerability exists in the add filter functionality of the rails_admin rails gem version 1.2.0. A specially crafted URL can cause an XSS flaw resulting in an attacker being able to execute arbitrary javascript on the victim's browser. An attacker can phish an authenticated user to trigger this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-12098?

2 open source packages ship an affected version, including rails_admin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails_admin` | RubyGems | All versions | 1.3.0 |
| `rails_admin` | RubyGems | All versions | 1.3.0 |

Products: Rails Admin Project Rails Admin.

## How do I fix CVE-2017-12098?

Upgrade rails_admin to 1.3.0 or later.

## Is CVE-2017-12098 being exploited?

There is no known exploitation of CVE-2017-12098 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-10522](https://insights.sbomify.com/CVE-2016-10522/): Cross-site request forgery in rails_admin (high 8.8)
- [CVE-2024-39308](https://insights.sbomify.com/CVE-2024-39308/): RailsAdmin Cross-site Scripting vulnerability in the list view (medium 6.8)
- [CVE-2020-36190](https://insights.sbomify.com/CVE-2020-36190/): rails_admin ruby gem XSS vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12098 and fix it if it is affected.

What it is: CVE-2017-12098 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12098 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails_admin (RubyGems): affected all versions; fixed in 1.3.0
- rails_admin (RubyGems): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12098/ (Markdown: https://insights.sbomify.com/CVE-2017-12098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12098
- OSV: https://osv.dev/vulnerability/CVE-2017-12098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12098/
Summaries are generated and may contain mistakes; the official description above is the record.
