CVE-2017-12156 Moodle XSS Vulnerability
Cross-site scripting in Moodle's contact form allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-12156?
CVE-2017-12156 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 18 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Moodle 3.x has XSS in the contact form on the "non-respondents" page in non-anonymous feedback.
Weakness: CWE-79
Which versions are affected by CVE-2017-12156?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.1.8 |
moodle/moodle Packagist | All versions | 3.1.8 |
moodle/moodle Packagist | From 3.2.0 | 3.2.5 |
moodle/moodle Packagist | From 3.2.0 | 3.2.5 |
moodle/moodle Packagist | From 3.3.0 | 3.3.2 |
moodle/moodle Packagist | From 3.3.0 | 3.3.2 |
Products include Moodle Moodle.
How do I fix CVE-2017-12156?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.8, 3.2.5 or 3.3.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-12156 being exploited?
There is no known exploitation of CVE-2017-12156 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-7mfw-g8x4-rq2w, UBUNTU-CVE-2017-12156.