CVE-2017-12157 Moodle sensitive information disclosure
Teachers can view user details in groups they lack access to, leading to unauthorized information disclosure in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-12157?
CVE-2017-12157 is a medium-severity vulnerability in Moodle Moodle, published on 18 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.
Weakness: CWE-200
Which versions are affected by CVE-2017-12157?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.1.8 |
moodle/moodle Packagist | All versions | 3.1.8 |
moodle/moodle Packagist | From 3.2.0 | 3.2.5 |
moodle/moodle Packagist | From 3.2.0 | 3.2.5 |
moodle/moodle Packagist | From 3.3.0 | 3.3.2 |
moodle/moodle Packagist | From 3.3.0 | 3.3.2 |
Products include Moodle Moodle.
How do I fix CVE-2017-12157?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.8, 3.2.5 or 3.3.2.
Is CVE-2017-12157 being exploited?
There is no known exploitation of CVE-2017-12157 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-gw95-48xq-gqf9, UBUNTU-CVE-2017-12157.